Flex and IE8-64bit

If your using Flex Builder 3 or Flash Builder 4 as your development tool, you may see this issue when testing your applications in Internet Explorer:

Internet Explorer is not finding the Flash Player plugin so you are seeing the alternate content.  The reason for this is most likely because you are testing in the 64-bit version of Internet Explorer 8.  Flash Player is currently not 64-bit compatible (see my note at the end of the post about this).  To fix this, you need to edit your preference in Flash Builder and update which version of Internet Explorer you it should use.  To do this, choose Window > Preferences.  Then choose General > Web Browser and edit the location for Internet Explorer:

Test your application again and you should see it display correctly.

NOTE: A couple weeks ago, Adobe posted a preview version of the next version of the Flash Player (code named “Square”) in Adobe Labs. You can download it and test it out.  It enables native 64-bit support on Linux, Mac OS, and Windows operating systems.

Comments are closed.